Planet Nomads Bug Tracking


Some Automatic lights don't go out



Attachments:

Screenshot.jpg (184.45 kB)
_main.db.zip (2.63 MB)
_working.db.zip (2.9 MB)

Comments

501idni
2019-11-27 13:02:54
Hello, there's a bug that I thought is already fixed. When you enter the vehicle in the "light on" area and then ride away, light does not register your exit/arrival. Only when you go on foot. Do you think this is also your case? Or did you "broken" the light another way?
cwsumner
2019-11-27 19:02:54
In my case, I was not in a vehicle. The lights were in small buildings and I was on foot.
One possible thing, these buildings used interior walls and door for the Exterior walls. They did not use the heavy armored walls.
HTH, thanks.
cwsumner
2019-11-29 23:05:29
(Sending again)
In my case, I was always walking. Also small buildings.
In most cases the walls used were interiour walls and door with small light. In two cases it worked ok, in one case worked at first and stuck later. There is one building a little larger with armored walls and door that failed with overhead light, but two other of the larger buildings light is ok. I do have several buildings, but not any of the huge ones I see in videos.
HTH, Thanks.
501idni
2019-12-02 12:02:10
Okay, thank you for reporting this, we'll need to look at it more deeply.
cwsumner
2019-12-02 18:15:11
Additional Info: I have two of the armored-wall lights, where one is stuck and one is working. I tried "clicking around" and it seems that I was able to get it working. I re-configured the light to Manual operation, turned the light off and re-configured back to automatic. Now both wall lights are working together!

I had used "E-switch" on some lights, before. This indicates a logic error in the lights. Possible quick fix: disable manual on/off when in Automatic mode. Alternative fix: When in Automatic mode and "E-switch" is used, force the mode back to Manual.

Note: If you send the line with the current light logic, I can analyse it and give you a correction. I do this all day. 8-)

HTH, thanks.
501idni
2019-12-12 14:21:27
I've tried big ceiling light in automatic mode, and after disabling it manually and walking away and back, it turned on automatically. Even when disabling it through the E key used on connected switch, it worked the same. I don't think there's a problem with this behavior.

Could you please find a more precise procedure to replicate it. Thanks.
cwsumner
2019-12-12 16:14:51
Yes,I will try various things and see if I can determine what triggers it. More later...
Thanks.

© 2018 Craneballs, All Rights Reserved